Having trouble connecting...

Dec 4, 2015 at 9:20 PM
Edited Dec 4, 2015 at 9:56 PM
I am trying to connect to a Cisco video endpoint using SS.NET. Here is my code...
        AuthenticationMethod authmeth = new PasswordAuthenticationMethod(username,password);
        KeyboardInteractiveAuthenticationMethod keyauth = new KeyboardInteractiveAuthenticationMethod(username);
        var connectionInfo = new ConnectionInfo(host, int.Parse(port), username, keyauth);
        using (var client = new SshClient(connectionInfo))
        {
            client.Connect();
             Thread.Sleep(3000);   
            client.Disconnect();
        }

This is the debug output I get...

SshNet.Logging Verbose: 1 : Initiating connect to '10.10.10.198:22'.
SshNet.Logging Verbose: 1 : Server version '2.0' on 'OpenSSH_6.5'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'KeyExchangeInitMessage': 'SSH_MSG_KEXINIT'.
SshNet.Logging Verbose: 1 : SendMessage to server 'KeyExchangeInitMessage': 'SSH_MSG_KEXINIT'.
SshNet.Logging Verbose: 1 : SendMessage to server 'KeyExchangeDhGroupExchangeRequest': 'SSH_MSG_KEX_DH_GEX_REQUEST'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'KeyExchangeDhGroupExchangeGroup': 'SSH_MSG_KEX_DH_GEX_GROUP'.
SshNet.Logging Verbose: 1 : SendMessage to server 'KeyExchangeDhGroupExchangeInit': 'SSH_MSG_KEX_DH_GEX_INIT'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'KeyExchangeDhGroupExchangeReply': 'SSH_MSG_KEX_DH_GEX_REPLY'.
SshNet.Logging Verbose: 1 : SendMessage to server 'NewKeysMessage': 'SSH_MSG_NEWKEYS'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'NewKeysMessage': 'SSH_MSG_NEWKEYS'.
SshNet.Logging Verbose: 1 : SendMessage to server 'ServiceRequestMessage': 'SSH_MSG_SERVICE_REQUEST'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'ServiceAcceptMessage': 'SSH_MSG_SERVICE_ACCEPT'.
SshNet.Logging Verbose: 1 : SendMessage to server 'RequestMessageNone': 'SSH_MSG_USERAUTH_REQUEST'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'FailureMessage': 'SSH_MSG_USERAUTH_FAILURE'.
SshNet.Logging Verbose: 1 : SendMessage to server 'RequestMessageKeyboardInteractive': 'SSH_MSG_USERAUTH_REQUEST'.
SshNet.Logging Verbose: 1 : ReceiveMessage from server: 'InformationRequestMessage': 'SSH_MSG_USERAUTH_INFO_REQUEST'.
SshNet.Logging Verbose: 1 : SendMessage to server 'InformationResponseMessage': 'SSH_MSG_USERAUTH_INFO_RESPONSE'.
A first chance exception of type 'Renci.SshNet.Common.SshConnectionException' occurred in Renci.SshNet.dll
A first chance exception of type 'Renci.SshNet.Common.SshConnectionException' occurred in Renci.SshNet.dll
An unhandled exception of type 'Renci.SshNet.Common.SshConnectionException' occurred in Renci.SshNet.dll
Additional information: An established connection was aborted by the server.


Can someone please help me understand why this is failing.
Thank you in advance for your assistance.


Anthony
Dec 7, 2015 at 3:31 PM
Can someone please give me some insight on this?