This project is read-only.

Cannot get .dll to load

Nov 16, 2012 at 3:44 PM

I recently ran across the SSH.NET Library and it is defiantly something I would like to use, unfortunately I am unable to get the .dll to load.  I am hoping someone can help me out.

My error is:

Exception calling "LoadFrom" with "1" argument(s): "Could not load file or assembly 'file:///C:\Users\aduser\Documents\WindowsPowerShell\Modules\SSH-Sessions\Renci.SshNet.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)"

At line:1 char:38+ [void][reflection.assembly]::LoadFrom <<<< ( (Resolve-Path ".\Documents\WindowsPowerShell\Modules\SSH-Sessions\Renci.SshNet.dll") )    + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException    + FullyQualifiedErrorId : DotNetMethodException


I am running powershell v.3, so I thought that might be an issue.  I tried on another machine in v.2, same problem.

I have tried in the 64 bit and 32 bit versions of the ISE, same problem.

I downloaded the .dll for .net 4.  I have verified that my ISE is running with v4

CLRVersion                     4.0.30319.296 


I am not sure where to go from here.