This project is read-only.

PowerShell 3 Support

Aug 23, 2012 at 8:14 AM

I tried to import the module to PowerShell 3, but I got the below error, I tried to use the latest DLL, also compiled the DOT.Net 4 binaries and load the DLL, but still nothing...

Any clue??  Thanks...

Import-Module : Could not load file or assembly 'file:///C:\Temp\SSH-Sessions\Renci.SshNet.dll' or one of its dependencies. Operation is not

supported. (Exception from HRESULT: 0x80131515)

At line:1 char:1

+ Import-Module C:\Temp\SSH-Sessions

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo : InvalidOperation: (:) [Import-Module], FileLoadException

+ FullyQualifiedErrorId : FormatXmlUpdateException,Microsoft.PowerShell.Commands.ImportModuleCommand

 

Dec 20, 2012 at 3:03 PM

Unblock the file did the trick for me.

Right click on  Renci.SshNet.dll --> Properties -->Unblock 

Jun 7, 2014 at 7:56 AM
It doesn't work for me with windows 8.1 after unblocking all files

Import-Module : File C:\Users\D\Documents\WindowsPowerShell\Modules\SSH-Sessions\SSH-Session
loaded because running scripts is disabled on this system.
At line:1 char:1
  • Import-Module SSH-Sessions
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : SecurityError: (:) [Import-Module], PSSecurityException
    • FullyQualifiedErrorId : UnauthorizedAccess,Microsoft.PowerShell.Commands.ImportModuleCommand
Jun 17, 2014 at 2:51 AM
You need to set your execution policy.

Run powershell as admin

If you run Get-ExecutionPolicy you will find that you're probably set to restricted.

So run Set-ExecutionPolicy RemoteSigned and then hit [Y] to allow the change.

now try your Import-Module SSH-Sessions

This worked for me on windows 8.1