This project is read-only.

SSH Server reports version 1.99

Nov 17, 2010 at 6:42 AM

I tried the connect to some Linux and AIX SSH-Servers. They all report "Server version 1.99".

The result of a connect ist the following error: Server version '1.99' is not supported.

IMHO "1.99" means that the SSH server supports both protocols, the old 1.5 and the new 2.0.
Is it possible to incorporate this case in the code?

Many thanks for your great work.


Nov 17, 2010 at 3:04 PM

Hi MabMan,

Unfortunatly I dont have an AIX here so I could try it and couldnt find spec for 1.99 implementation. but from what I seen in other library, 1.99 should be the same as 2.00.

Do you mind to do a quick test for me and let me know if it works?

just replace line :

if (!version.Equals("2.0"))

with :

if (!version.Equals("2.0") || !version.Equals("1.99"))

in Session file.

Then it will allow version 1.99 as well and let me know if it works.




Nov 17, 2010 at 3:05 PM

Another thing,


from what I read is that 2.0 is now to be widely used and 1.x is more then 10 years old version, so thats why I choose to implement only 2.0 version.

Nov 17, 2010 at 5:19 PM

Hi Oleg,

I did your quicktest und it worked.

In chapter 5.1 of the following RFC document at you can find a description how a client has to interpret the version 1.99.
So I think your quick test is also the final solution.


Nov 17, 2010 at 5:38 PM

Thanks MabMan,


I will incorporate those changes into next version.



Nov 17, 2010 at 5:47 PM


I just concerned about one comment in spec "server SHOULD NOT send the Carriage Return character (ASCII 13) after the identification string.".

I will add this feature, once I implement it and would like to see if it still forks for you.