Minimum version required for SHA-256

Jul 6 at 7:30 PM
I have the SSH.NET library 4.0.30319 and I want to make sure this version will support SHA-256, or if there is a newer version I need.
Jul 6 at 7:41 PM
Also, if the version we have does support SHA-256 what special settings do we need to have to make it work?