This project is read-only.

Private key cipher "AES-128-CBC" is not supported.

Jun 5, 2012 at 3:29 AM

As displayed on list of Features:

Supports 3des-cbc, aes128-cbc, aes192-cbc, aes256-cbc, aes128-ctr, aes192-ctr, aes256-ctr, blowfish-cbc and cast128-cbc encryptions.


PrivateKeyConnectionInfo pKeyConn = new PrivateKeyConnectionInfo("", "testuser", new PrivateKeyFile("./keyfiles/myKeyFile.ppk","password"));


using private key file with passphrase and during runtime i get this exception.

Private key cipher "AES-128-CBC" is not supported.

is this currently not supported? or keyfiles with passphrase not supported? 



Jun 5, 2012 at 9:26 PM




you right,

there are two different encyrptions, one used to communicate with the server, and another one to decrypt key files.


Before leaving for vacation, I tried to play with AES encryption for key files, but for some reason it doesnt work, even so I know AES works correctly, so I assume there is something else I am missing which is relates to encrypting private key files.


I will try to add support for it as soon as I can, but meanwhile can you log it as an issue, if its not there already, so I dont forget to work on it.




Dec 18, 2012 at 9:55 AM

I get the same error using the last version of the library. Is this issue still open?

Thank you.

Dec 18, 2012 at 4:58 PM

See here:

My diff works for me. But no reply by the developers since posting it :(

Dec 19, 2012 at 4:55 PM



Just added support for AES encryption.


Please take a look at latest source code.