This project is read-only.

Scp file names.

Dec 26, 2011 at 7:26 PM

Hi Oleg,

 Once again, thanks a lot for your help, I found something when I was connecting on different machines for SCPing files, In Unix server A a copy the files with no problem into the folder that the session assing me, but on the Unix server B the name of the file copied was added double quotes, so if the file name is: file1.txt, in Unix server A the name of the file it's:  file1.txt but on Unix server B it's: "file1.txt". 

 I was looking into the code and I found this line: channel.SendExecRequest(string.Format("scp -qt \"{0}\"", filename));(File ScpClient.NET.cs, line 33), and I changed for this one: channel.SendExecRequest("scp -qt " + filename);  

We think that this may happen for the encoding configuration on the remote host, I don't know if I have to post this here or in another place,

Regards,

Raúl.

Coordinator
Dec 26, 2011 at 7:30 PM

Can you please open an issue for this problem and i will take a look at it as soon as i can?

Thanks,
Oleg

On Dec 26, 2011 2:26 PM, "sisvania" <notifications@codeplex.com> wrote:

From: sisvania

Hi Oleg,

Once again, thanks a lot for your help, I found something when I was connecting on different machines for SCPing files, In Unix server A a copy the files with no problem into the folder that the session assing me, but on the Unix server B the name of the file copied was added double quotes, so if the file name is: file1.txt, in Unix server A the name of the file it's: file1.txt but on Unix server B it's: "file1.txt".

I was looking into the code and I found this line: channel.SendExecRequest(string.Format("scp -qt \"{0}\"", filename));(File ScpClient.NET.cs, line 33), and I changed for this one: channel.SendExecRequest("scp -qt " + filename);

We think that this may happen for the encoding configuration on the remote host, I don't know if I have to post this here or in another place,

Regards,

Raúl.

Read the full discussion online.

To add a post to this discussion, reply to this email (sshnet@discussions.codeplex.com)

To start a new discussion for this project, email sshnet@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com